Move BREE of o.e.dltk.ruby.basicdebugger to Java 1.6

With DLTK core being at 1.6 it makes no sense to stay lower in dependent
modules.
Also fix a new warning appeared after that. 

Change-Id: I13199189f8a69f46722af547cd9c602262233b98
Signed-off-by: Alexander Kurtakov <akurtako@redhat.com>
diff --git a/plugins/org.eclipse.dltk.ruby.basicdebugger/.classpath b/plugins/org.eclipse.dltk.ruby.basicdebugger/.classpath
index 304e861..ad32c83 100644
--- a/plugins/org.eclipse.dltk.ruby.basicdebugger/.classpath
+++ b/plugins/org.eclipse.dltk.ruby.basicdebugger/.classpath
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <classpath>
-	<classpathentry kind="src" path="src"/>
-	<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5"/>
+	<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6"/>
 	<classpathentry kind="con" path="org.eclipse.pde.core.requiredPlugins"/>
+	<classpathentry kind="src" path="src"/>
 	<classpathentry kind="output" path="bin"/>
 </classpath>
diff --git a/plugins/org.eclipse.dltk.ruby.basicdebugger/.settings/org.eclipse.jdt.core.prefs b/plugins/org.eclipse.dltk.ruby.basicdebugger/.settings/org.eclipse.jdt.core.prefs
index af0f20f..c537b63 100644
--- a/plugins/org.eclipse.dltk.ruby.basicdebugger/.settings/org.eclipse.jdt.core.prefs
+++ b/plugins/org.eclipse.dltk.ruby.basicdebugger/.settings/org.eclipse.jdt.core.prefs
@@ -1,7 +1,7 @@
 eclipse.preferences.version=1
 org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
-org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
-org.eclipse.jdt.core.compiler.compliance=1.5
+org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.6
+org.eclipse.jdt.core.compiler.compliance=1.6
 org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
 org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
-org.eclipse.jdt.core.compiler.source=1.5
+org.eclipse.jdt.core.compiler.source=1.6
diff --git a/plugins/org.eclipse.dltk.ruby.basicdebugger/META-INF/MANIFEST.MF b/plugins/org.eclipse.dltk.ruby.basicdebugger/META-INF/MANIFEST.MF
index 4acee2d..6587d69 100644
--- a/plugins/org.eclipse.dltk.ruby.basicdebugger/META-INF/MANIFEST.MF
+++ b/plugins/org.eclipse.dltk.ruby.basicdebugger/META-INF/MANIFEST.MF
@@ -17,6 +17,6 @@
  org.eclipse.dltk.ruby.core
 Bundle-ActivationPolicy: lazy
 Bundle-Vendor: %providerName
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Bundle-Localization: plugin
 
diff --git a/plugins/org.eclipse.dltk.ruby.basicdebugger/src/org/eclipse/dltk/ruby/basicdebugger/RubyBasicDebuggerRunnerFactory.java b/plugins/org.eclipse.dltk.ruby.basicdebugger/src/org/eclipse/dltk/ruby/basicdebugger/RubyBasicDebuggerRunnerFactory.java
index bd3dc0e..7c04386 100644
--- a/plugins/org.eclipse.dltk.ruby.basicdebugger/src/org/eclipse/dltk/ruby/basicdebugger/RubyBasicDebuggerRunnerFactory.java
+++ b/plugins/org.eclipse.dltk.ruby.basicdebugger/src/org/eclipse/dltk/ruby/basicdebugger/RubyBasicDebuggerRunnerFactory.java
@@ -1,11 +1,10 @@
 /*******************************************************************************
- * Copyright (c) 2005, 2007 IBM Corporation and others.
+ * Copyright (c) 2005, 2016 IBM Corporation and others.
  * All rights reserved. This program and the accompanying materials
  * are made available under the terms of the Eclipse Public License v1.0
  * which accompanies this distribution, and is available at
  * http://www.eclipse.org/legal/epl-v10.html
  *
- 
  *******************************************************************************/
 
 package org.eclipse.dltk.ruby.basicdebugger;
@@ -14,8 +13,8 @@
 import org.eclipse.dltk.launching.IInterpreterRunner;
 import org.eclipse.dltk.launching.IInterpreterRunnerFactory;
 
-public class RubyBasicDebuggerRunnerFactory implements
-		IInterpreterRunnerFactory {
+public class RubyBasicDebuggerRunnerFactory implements IInterpreterRunnerFactory {
+	@Override
 	public IInterpreterRunner createRunner(IInterpreterInstall install) {
 		return new RubyBasicDebuggerRunner(install);
 	}