update versions for 3.12

Change-Id: Id95aaf74bae44c74df715fdef370338a6d97cf70
diff --git a/org.eclipse.mylyn.examples.hudson.standalone/pom.xml b/org.eclipse.mylyn.examples.hudson.standalone/pom.xml
index 84a531b..3809101 100644
--- a/org.eclipse.mylyn.examples.hudson.standalone/pom.xml
+++ b/org.eclipse.mylyn.examples.hudson.standalone/pom.xml
@@ -4,7 +4,7 @@
 
   <groupId>org.eclipse.mylyn.incubator</groupId>
   <artifactId>org.eclipse.mylyn.examples.hudson.standalone</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>jar</packaging>
 
   <name>org.eclipse.mylyn.examples.hudson.standalone</name>
@@ -70,27 +70,27 @@
     <dependency>
       <groupId>org.eclipse.mylyn.builds</groupId>
       <artifactId>org.eclipse.mylyn.builds.core</artifactId>
-      <version>1.3.0-SNAPSHOT</version>
+      <version>1.4.0-SNAPSHOT</version>
     </dependency>
     <dependency>
       <groupId>org.eclipse.mylyn.builds</groupId>
       <artifactId>org.eclipse.mylyn.hudson.core</artifactId>
-      <version>1.3.0-SNAPSHOT</version>
+      <version>1.4.0-SNAPSHOT</version>
     </dependency>
     <dependency>
       <groupId>org.eclipse.mylyn.commons</groupId>
       <artifactId>org.eclipse.mylyn.commons.core</artifactId>
-      <version>3.11.0-SNAPSHOT</version>
+      <version>3.12.0-SNAPSHOT</version>
     </dependency>
     <dependency>
       <groupId>org.eclipse.mylyn.commons</groupId>
       <artifactId>org.eclipse.mylyn.commons.repositories.core</artifactId>
-      <version>1.3.0-SNAPSHOT</version>
+      <version>1.4.0-SNAPSHOT</version>
     </dependency>
     <dependency>
       <groupId>org.eclipse.mylyn.commons</groupId>
       <artifactId>org.eclipse.mylyn.commons.repositories.http.core</artifactId>
-      <version>1.3.0-SNAPSHOT</version>
+      <version>1.4.0-SNAPSHOT</version>
     </dependency>
   </dependencies>
 
diff --git a/org.eclipse.mylyn.examples.monitor.study/pom.xml b/org.eclipse.mylyn.examples.monitor.study/pom.xml
index 00980f6..8066c72 100644
--- a/org.eclipse.mylyn.examples.monitor.study/pom.xml
+++ b/org.eclipse.mylyn.examples.monitor.study/pom.xml
@@ -5,7 +5,7 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.monitor.study</artifactId>
   <version>1.0.0</version>
diff --git a/org.eclipse.mylyn.experimental-sdk-feature/feature.xml b/org.eclipse.mylyn.experimental-sdk-feature/feature.xml
index a224e14..2d47b50 100644
--- a/org.eclipse.mylyn.experimental-sdk-feature/feature.xml
+++ b/org.eclipse.mylyn.experimental-sdk-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.experimental_sdk_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -29,9 +29,9 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn.monitor_feature" version="3.11.0" match="compatible"/>
-      <import feature="org.eclipse.mylyn.sandbox.ui_feature" version="3.11.0" match="compatible"/>
-      <import feature="org.eclipse.mylyn.web.tasks_feature" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.monitor_feature" version="3.12.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.sandbox.ui_feature" version="3.12.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.web.tasks_feature" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.experimental-sdk-feature/pom.xml b/org.eclipse.mylyn.experimental-sdk-feature/pom.xml
index 46f34f9..8e1864b 100644
--- a/org.eclipse.mylyn.experimental-sdk-feature/pom.xml
+++ b/org.eclipse.mylyn.experimental-sdk-feature/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.experimental_sdk_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.ide.capabilities/META-INF/MANIFEST.MF b/org.eclipse.mylyn.ide.capabilities/META-INF/MANIFEST.MF
index 54387f4..cbce2b7 100644
--- a/org.eclipse.mylyn.ide.capabilities/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.ide.capabilities/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.mylyn.ide.capabilities;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: %Bundle-Vendor
 Require-Bundle: org.eclipse.ui
 Bundle-Localization: plugin
diff --git a/org.eclipse.mylyn.ide.capabilities/pom.xml b/org.eclipse.mylyn.ide.capabilities/pom.xml
index 62ea08c..1a2078f 100644
--- a/org.eclipse.mylyn.ide.capabilities/pom.xml
+++ b/org.eclipse.mylyn.ide.capabilities/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.ide.capabilities</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.ide.dev/META-INF/MANIFEST.MF b/org.eclipse.mylyn.ide.dev/META-INF/MANIFEST.MF
index 9f6911b..6ea3099 100644
--- a/org.eclipse.mylyn.ide.dev/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.ide.dev/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.mylyn.ide.dev;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: %Bundle-Vendor
 Require-Bundle: org.eclipse.ui
 Bundle-Localization: plugin
diff --git a/org.eclipse.mylyn.ide.dev/pom.xml b/org.eclipse.mylyn.ide.dev/pom.xml
index 998a84e..241211d 100644
--- a/org.eclipse.mylyn.ide.dev/pom.xml
+++ b/org.eclipse.mylyn.ide.dev/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.ide.dev</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
 </project>
diff --git a/org.eclipse.mylyn.incubator-site/pom.xml b/org.eclipse.mylyn.incubator-site/pom.xml
index 3ff8894..15f8114 100644
--- a/org.eclipse.mylyn.incubator-site/pom.xml
+++ b/org.eclipse.mylyn.incubator-site/pom.xml
@@ -14,10 +14,10 @@
   <parent>
     <groupId>org.eclipse.mylyn.incubator</groupId>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>incubator-site</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-update-site</packaging>
   <name>Mylyn Incubator for Mylyn 3.9</name>
   <properties>
diff --git a/org.eclipse.mylyn.monitor.reports/META-INF/MANIFEST.MF b/org.eclipse.mylyn.monitor.reports/META-INF/MANIFEST.MF
index f1dec6c..e82c57a 100644
--- a/org.eclipse.mylyn.monitor.reports/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.monitor.reports/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Usage Monitor (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.monitor.reports; singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Activator: org.eclipse.mylyn.internal.monitor.reports.MonitorReportsPlugin
 Bundle-Vendor: Eclipse Mylyn
 Require-Bundle: org.eclipse.ui,
diff --git a/org.eclipse.mylyn.monitor.reports/pom.xml b/org.eclipse.mylyn.monitor.reports/pom.xml
index 9eafec0..500d07d 100644
--- a/org.eclipse.mylyn.monitor.reports/pom.xml
+++ b/org.eclipse.mylyn.monitor.reports/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.monitor.reports</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.monitor.usage-feature/feature.xml b/org.eclipse.mylyn.monitor.usage-feature/feature.xml
index 01515c3..99624e8 100644
--- a/org.eclipse.mylyn.monitor.usage-feature/feature.xml
+++ b/org.eclipse.mylyn.monitor.usage-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.monitor_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -30,8 +30,8 @@
 
    <requires>
       <import feature="org.eclipse.rcp" version="3.3.0" match="greaterOrEqual"/>
-      <import feature="org.eclipse.mylyn.commons" version="3.11.0" match="compatible"/>
-      <import feature="org.eclipse.mylyn.monitor" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.commons" version="3.12.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.monitor" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.monitor.usage-feature/pom.xml b/org.eclipse.mylyn.monitor.usage-feature/pom.xml
index 4510864..a1da117 100644
--- a/org.eclipse.mylyn.monitor.usage-feature/pom.xml
+++ b/org.eclipse.mylyn.monitor.usage-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.monitor_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.monitor.usage/META-INF/MANIFEST.MF b/org.eclipse.mylyn.monitor.usage/META-INF/MANIFEST.MF
index 4709df6..7a4b1b3 100644
--- a/org.eclipse.mylyn.monitor.usage/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.monitor.usage/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Usage Monitor (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.monitor.usage;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Activator: org.eclipse.mylyn.internal.monitor.usage.UiUsageMonitorPlugin
 Require-Bundle: org.eclipse.ui,
  org.eclipse.core.runtime,
diff --git a/org.eclipse.mylyn.monitor.usage/pom.xml b/org.eclipse.mylyn.monitor.usage/pom.xml
index 3df905d..aa62025 100644
--- a/org.eclipse.mylyn.monitor.usage/pom.xml
+++ b/org.eclipse.mylyn.monitor.usage/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.monitor.usage</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.sandbox.dev-feature/feature.xml b/org.eclipse.mylyn.sandbox.dev-feature/feature.xml
index aa42d7b..330ecd9 100644
--- a/org.eclipse.mylyn.sandbox.dev-feature/feature.xml
+++ b/org.eclipse.mylyn.sandbox.dev-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.sandbox.dev_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -29,7 +29,7 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn.context_feature" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.context_feature" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.sandbox.dev-feature/pom.xml b/org.eclipse.mylyn.sandbox.dev-feature/pom.xml
index 442cfe4..bbff06f 100644
--- a/org.eclipse.mylyn.sandbox.dev-feature/pom.xml
+++ b/org.eclipse.mylyn.sandbox.dev-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.dev_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.sandbox.dev/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.dev/META-INF/MANIFEST.MF
index fc55b6c..0160b58 100644
--- a/org.eclipse.mylyn.sandbox.dev/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.dev/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Incubator (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.sandbox.dev;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Require-Bundle: org.eclipse.core.resources,
  org.eclipse.core.runtime,
  org.eclipse.jdt.core;resolution:=optional,
diff --git a/org.eclipse.mylyn.sandbox.dev/pom.xml b/org.eclipse.mylyn.sandbox.dev/pom.xml
index 47a0533..15f6433 100644
--- a/org.eclipse.mylyn.sandbox.dev/pom.xml
+++ b/org.eclipse.mylyn.sandbox.dev/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.dev</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.sandbox.search-feature/feature.xml b/org.eclipse.mylyn.sandbox.search-feature/feature.xml
index e64f371..b861577 100644
--- a/org.eclipse.mylyn.sandbox.search-feature/feature.xml
+++ b/org.eclipse.mylyn.sandbox.search-feature/feature.xml
@@ -2,7 +2,7 @@
 <feature
       id="org.eclipse.mylyn.sandbox.search"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
diff --git a/org.eclipse.mylyn.sandbox.search-feature/pom.xml b/org.eclipse.mylyn.sandbox.search-feature/pom.xml
index 69fad31..ccea826 100644
--- a/org.eclipse.mylyn.sandbox.search-feature/pom.xml
+++ b/org.eclipse.mylyn.sandbox.search-feature/pom.xml
@@ -7,9 +7,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.search</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.sandbox.search.ui.windows/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.search.ui.windows/META-INF/MANIFEST.MF
index eab25e3..a564da4 100644
--- a/org.eclipse.mylyn.sandbox.search.ui.windows/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.search.ui.windows/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.mylyn.sandbox.search.ui.windows;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: %Bundle-Vendor
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
diff --git a/org.eclipse.mylyn.sandbox.search.ui.windows/pom.xml b/org.eclipse.mylyn.sandbox.search.ui.windows/pom.xml
index 44ab189..6646db3 100644
--- a/org.eclipse.mylyn.sandbox.search.ui.windows/pom.xml
+++ b/org.eclipse.mylyn.sandbox.search.ui.windows/pom.xml
@@ -7,10 +7,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.search.ui.windows</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.sandbox.search.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.search.ui/META-INF/MANIFEST.MF
index 3860d3f..5c7f936 100644
--- a/org.eclipse.mylyn.sandbox.search.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.search.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.mylyn.sandbox.search.ui;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: %Bundle-Vendor
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Require-Bundle: org.eclipse.core.runtime;bundle-version="3.5.0",
diff --git a/org.eclipse.mylyn.sandbox.search.ui/pom.xml b/org.eclipse.mylyn.sandbox.search.ui/pom.xml
index f335360..e53b40b 100644
--- a/org.eclipse.mylyn.sandbox.search.ui/pom.xml
+++ b/org.eclipse.mylyn.sandbox.search.ui/pom.xml
@@ -7,10 +7,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.search.ui</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.sandbox.tests/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.tests/META-INF/MANIFEST.MF
index 00b5721..64f6c9c 100644
--- a/org.eclipse.mylyn.sandbox.tests/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.tests/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Incubator (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.sandbox.tests;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: Eclipse Mylyn
 Require-Bundle: org.eclipse.core.runtime,
  org.eclipse.core.resources,
diff --git a/org.eclipse.mylyn.sandbox.tests/pom.xml b/org.eclipse.mylyn.sandbox.tests/pom.xml
index 8131e45..e3dc7e7 100644
--- a/org.eclipse.mylyn.sandbox.tests/pom.xml
+++ b/org.eclipse.mylyn.sandbox.tests/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.tests</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-test-plugin</packaging>
   <properties>
     <test.suite>${project.artifactId}.AllSandboxTests</test.suite>
diff --git a/org.eclipse.mylyn.sandbox.ui-feature/feature.xml b/org.eclipse.mylyn.sandbox.ui-feature/feature.xml
index f113684..1d2111a 100644
--- a/org.eclipse.mylyn.sandbox.ui-feature/feature.xml
+++ b/org.eclipse.mylyn.sandbox.ui-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.sandbox.ui_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -29,9 +29,9 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn.context_feature" version="3.11.0" match="compatible"/>
-      <import feature="org.eclipse.mylyn.pde_feature" version="3.11.0" match="compatible"/>
-      <import feature="org.eclipse.mylyn.java_feature" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.context_feature" version="3.12.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.pde_feature" version="3.12.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.java_feature" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.sandbox.ui-feature/pom.xml b/org.eclipse.mylyn.sandbox.ui-feature/pom.xml
index c312132..ea0f1ef 100644
--- a/org.eclipse.mylyn.sandbox.ui-feature/pom.xml
+++ b/org.eclipse.mylyn.sandbox.ui-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.ui_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
index 47c741f..37321ed 100644
--- a/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.sandbox.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Incubator (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.sandbox.ui;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Activator: org.eclipse.mylyn.internal.sandbox.ui.SandboxUiPlugin
 Require-Bundle: org.eclipse.core.runtime,
  org.eclipse.core.resources,
diff --git a/org.eclipse.mylyn.sandbox.ui/pom.xml b/org.eclipse.mylyn.sandbox.ui/pom.xml
index c499387..3697435 100644
--- a/org.eclipse.mylyn.sandbox.ui/pom.xml
+++ b/org.eclipse.mylyn.sandbox.ui/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.sandbox.ui</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.tests.performance-feature/feature.xml b/org.eclipse.mylyn.tests.performance-feature/feature.xml
index c7e8f46..11ebed0 100644
--- a/org.eclipse.mylyn.tests.performance-feature/feature.xml
+++ b/org.eclipse.mylyn.tests.performance-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.tests.performance_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
    <description url="http://eclipse.org/mylyn">
diff --git a/org.eclipse.mylyn.tests.performance-feature/pom.xml b/org.eclipse.mylyn.tests.performance-feature/pom.xml
index 6959124..829f923 100644
--- a/org.eclipse.mylyn.tests.performance-feature/pom.xml
+++ b/org.eclipse.mylyn.tests.performance-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.tests.performance_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.tests.performance/META-INF/MANIFEST.MF b/org.eclipse.mylyn.tests.performance/META-INF/MANIFEST.MF
index 1429d25..d8984f0 100644
--- a/org.eclipse.mylyn.tests.performance/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.tests.performance/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Performance Tests
 Bundle-SymbolicName: org.eclipse.mylyn.tests.performance;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: Eclipse Mylyn
 Require-Bundle: org.eclipse.core.resources,
  org.eclipse.core.runtime,
diff --git a/org.eclipse.mylyn.tests.performance/pom.xml b/org.eclipse.mylyn.tests.performance/pom.xml
index e2029ff..3d03ce0 100644
--- a/org.eclipse.mylyn.tests.performance/pom.xml
+++ b/org.eclipse.mylyn.tests.performance/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.tests.performance</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-test-plugin</packaging>
   <properties>
     <test.suite>${project.artifactId}.AllPerformanceTests</test.suite>
diff --git a/org.eclipse.mylyn.tests.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.tests.ui/META-INF/MANIFEST.MF
index 57e682f..e8ac70f 100644
--- a/org.eclipse.mylyn.tests.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.tests.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn UI Tests
 Bundle-SymbolicName: org.eclipse.mylyn.tests.ui;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Vendor: Eclipse Mylyn
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Require-Bundle: org.eclipse.swtbot.eclipse.core;bundle-version="2.0.0",
diff --git a/org.eclipse.mylyn.tests.ui/pom.xml b/org.eclipse.mylyn.tests.ui/pom.xml
index 5902c68..3e70e65 100644
--- a/org.eclipse.mylyn.tests.ui/pom.xml
+++ b/org.eclipse.mylyn.tests.ui/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.tests.ui</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-test-plugin</packaging>
   <properties>
     <test.suite>${project.artifactId}.AllUiTests</test.suite>
diff --git a/org.eclipse.mylyn.trac.wiki-feature/feature.xml b/org.eclipse.mylyn.trac.wiki-feature/feature.xml
index cfbcaea..dedb70c 100644
--- a/org.eclipse.mylyn.trac.wiki-feature/feature.xml
+++ b/org.eclipse.mylyn.trac.wiki-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.trac.wiki_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -29,7 +29,7 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn.trac_feature" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn.trac_feature" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.trac.wiki-feature/pom.xml b/org.eclipse.mylyn.trac.wiki-feature/pom.xml
index 96d96af..e784df9 100644
--- a/org.eclipse.mylyn.trac.wiki-feature/pom.xml
+++ b/org.eclipse.mylyn.trac.wiki-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.trac.wiki_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.trac.wiki/META-INF/MANIFEST.MF b/org.eclipse.mylyn.trac.wiki/META-INF/MANIFEST.MF
index aa230c7..cae86c8 100644
--- a/org.eclipse.mylyn.trac.wiki/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.trac.wiki/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Trac Connector (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.trac.wiki;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-ActivationPolicy: lazy
 Bundle-Vendor: Eclipse Mylyn
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
diff --git a/org.eclipse.mylyn.trac.wiki/pom.xml b/org.eclipse.mylyn.trac.wiki/pom.xml
index 9036229..8a44f9b 100644
--- a/org.eclipse.mylyn.trac.wiki/pom.xml
+++ b/org.eclipse.mylyn.trac.wiki/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.trac.wiki</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.web.tasks-feature/feature.xml b/org.eclipse.mylyn.web.tasks-feature/feature.xml
index c535905..58964ef 100644
--- a/org.eclipse.mylyn.web.tasks-feature/feature.xml
+++ b/org.eclipse.mylyn.web.tasks-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.web.tasks_feature"
       label="%featureName"
-      version="3.11.0.qualifier"
+      version="3.12.0.qualifier"
       provider-name="%providerName"
       plugin="org.eclipse.mylyn.sandbox.ui">
 
@@ -29,7 +29,7 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn_feature" version="3.11.0" match="compatible"/>
+      <import feature="org.eclipse.mylyn_feature" version="3.12.0" match="compatible"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.web.tasks-feature/pom.xml b/org.eclipse.mylyn.web.tasks-feature/pom.xml
index 6837d31..5597be4 100644
--- a/org.eclipse.mylyn.web.tasks-feature/pom.xml
+++ b/org.eclipse.mylyn.web.tasks-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.web.tasks_feature</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.web.tasks/META-INF/MANIFEST.MF b/org.eclipse.mylyn.web.tasks/META-INF/MANIFEST.MF
index 57642a3..3cf154b 100644
--- a/org.eclipse.mylyn.web.tasks/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.web.tasks/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name
 Bundle-SymbolicName: org.eclipse.mylyn.web.tasks;singleton:=true
-Bundle-Version: 3.11.0.qualifier
+Bundle-Version: 3.12.0.qualifier
 Bundle-Activator: org.eclipse.mylyn.internal.web.tasks.TasksWebPlugin
 Bundle-Vendor: %Bundle-Vendor
 Require-Bundle: com.sun.syndication;bundle-version="0.9.0",
diff --git a/org.eclipse.mylyn.web.tasks/pom.xml b/org.eclipse.mylyn.web.tasks/pom.xml
index f0bc260..eb3bd6f 100644
--- a/org.eclipse.mylyn.web.tasks/pom.xml
+++ b/org.eclipse.mylyn.web.tasks/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.web.tasks</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/org.eclipse.mylyn.wikitext.sandbox-feature/feature.xml b/org.eclipse.mylyn.wikitext.sandbox-feature/feature.xml
index b362a78..700e37c 100644
--- a/org.eclipse.mylyn.wikitext.sandbox-feature/feature.xml
+++ b/org.eclipse.mylyn.wikitext.sandbox-feature/feature.xml
@@ -12,7 +12,7 @@
 <feature
       id="org.eclipse.mylyn.wikitext.sandbox"
       label="%featureName"
-      version="2.0.0.qualifier"
+      version="2.1.0.qualifier"
       provider-name="%providerName">
 
    <description>
@@ -28,7 +28,7 @@
    </license>
 
    <requires>
-      <import feature="org.eclipse.mylyn.wikitext_feature" version="2.0.0" match="greaterOrEqual"/>
+      <import feature="org.eclipse.mylyn.wikitext_feature" version="2.1.0" match="greaterOrEqual"/>
    </requires>
 
    <plugin
diff --git a/org.eclipse.mylyn.wikitext.sandbox-feature/pom.xml b/org.eclipse.mylyn.wikitext.sandbox-feature/pom.xml
index 5490bd3..397ce6f 100644
--- a/org.eclipse.mylyn.wikitext.sandbox-feature/pom.xml
+++ b/org.eclipse.mylyn.wikitext.sandbox-feature/pom.xml
@@ -5,9 +5,9 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.wikitext.sandbox</artifactId>
-  <version>2.0.0-SNAPSHOT</version>
+  <version>2.1.0-SNAPSHOT</version>
   <packaging>eclipse-feature</packaging>
 </project>
diff --git a/org.eclipse.mylyn.wikitext.sandbox.ui/META-INF/MANIFEST.MF b/org.eclipse.mylyn.wikitext.sandbox.ui/META-INF/MANIFEST.MF
index 79e3ca2..922ea8a 100644
--- a/org.eclipse.mylyn.wikitext.sandbox.ui/META-INF/MANIFEST.MF
+++ b/org.eclipse.mylyn.wikitext.sandbox.ui/META-INF/MANIFEST.MF
@@ -2,7 +2,7 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: Mylyn Incubator (Incubation)
 Bundle-SymbolicName: org.eclipse.mylyn.wikitext.sandbox.ui
-Bundle-Version: 2.0.0.qualifier
+Bundle-Version: 2.1.0.qualifier
 Bundle-Vendor: Eclipse.org
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6
 Require-Bundle: org.eclipse.mylyn.wikitext.core;bundle-version="1.3.0",
diff --git a/org.eclipse.mylyn.wikitext.sandbox.ui/pom.xml b/org.eclipse.mylyn.wikitext.sandbox.ui/pom.xml
index f4f121d..7096f7f 100644
--- a/org.eclipse.mylyn.wikitext.sandbox.ui/pom.xml
+++ b/org.eclipse.mylyn.wikitext.sandbox.ui/pom.xml
@@ -5,10 +5,10 @@
   <parent>
     <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
     <groupId>org.eclipse.mylyn.incubator</groupId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
   </parent>
   <artifactId>org.eclipse.mylyn.wikitext.sandbox.ui</artifactId>
-  <version>2.0.0-SNAPSHOT</version>
+  <version>2.1.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <build>
     <plugins>
diff --git a/pom.xml b/pom.xml
index 3bb9fc7..ee66cd9 100644
--- a/pom.xml
+++ b/pom.xml
@@ -5,12 +5,12 @@
   <parent>
     <groupId>org.eclipse.mylyn</groupId>
     <artifactId>org.eclipse.mylyn-parent</artifactId>
-    <version>3.11.0-SNAPSHOT</version>
+    <version>3.12.0-SNAPSHOT</version>
     <relativePath>../org.eclipse.mylyn/org.eclipse.mylyn-parent</relativePath>
   </parent>
   <groupId>org.eclipse.mylyn.incubator</groupId>
   <artifactId>org.eclipse.mylyn.incubator-parent</artifactId>
-  <version>3.11.0-SNAPSHOT</version>
+  <version>3.12.0-SNAPSHOT</version>
   <name>Mylyn Incubator</name>
   <packaging>pom</packaging>
   <properties>