blob: 7551cb90babc469784c725456ee65034f346dfcf [file] [log] [blame]
<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Author" content="IBM">
<meta name="GENERATOR" content="Mozilla/4.75 [en] (WinNT; U) [Netscape]">
<title>Java Debug Release Notes</title>
</head>
<body>
<h1>Eclipse 3.5 Java Debug Build Notes</h1>
<h2>Summary of API changes in 3.5</h2>
<h3>Configurable problem severity when a compatible JRE cannot be bound to specified execution environment </h3>
<p><strong>Description:</strong> In release 3.4 and earlier, when a project was bound to an execution environment (for example, J2SE-1.4), and the workspace did not have a strictly compatible JRE installed (for example, only a J2SE-1.5 JRE was available), a build path problem with a warning severity was issued. Since 3.5, API has been added to allow the severity of the problem to be ignored, a warning, or an error. See the newly added constants in JavaRuntime: <code>PREF_STRICTLY_COMPATIBLE_JRE_NOT_AVAILABLE</code>, <code>VALUE_IGNORE</code>, <code>VALUE_WARNING</code>, and <code>VALUE_ERROR</code>.</p>
<h3>OSGi Profile Properties for IExecutionEnvironment </h3>
<p><strong>What is affected:</strong> Clients contributing an execution environment can provide an associated OSGi system profile properties file. </p>
<p><strong>Description:</strong> In release 3.4 and earlier, clients could contribute an execution environment, but when that environment was bound to a build path for a plug-in project, default compiler compliance settings were not set appropriately. Since 3.5, clients may specify an OSGi system profile properties file with an execution environment. The properties file provides information about system packages, default source and target compiler settings, etc. When provided, tooling will be able to leverage the information to create default access rules for system packages and properly set default compiler compliance settings for projects bound to the contributed environment. See the newly added method <code>IExecutionEnvironment.getProfileProperties()</code> and the new extension point attribute <code>profileProperties</code>.</p>
<p><strong>Action required:</strong> Clients contributing an execution environment should provide an associated OSGi system profile properties file. </p>
<h2>Milestone 4 - December 9, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=236296">Bug 236296</a>: update the classpath settings feature sets wrong project compiler compliance level<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=212605">Bug 212605</a>: [launching] Mac OS X launcher should not hide the necessary -XstartOnFirstThread<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=257466">Bug 257466</a>: Hot Code Replace Fail dlg has two buttons with _D_<br>
<h2>November 18, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=255031">Bug 255031</a>: Missing EEs prevent project to build<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=255381">Bug 255381</a>: Inconsistent Default Filtered resources<br>
<h2>November 11, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=253022">Bug 253022</a>: Suppport for new OSGi/Minimum-1.2 Execution environment<br>
<h2>November 4, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=252521">Bug 252521</a>: VM Disconnection exception when program terminates with thread group turned on<br>
<h2>October 21, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=244395">Bug 244395</a>: [refactoring] [launch config refactoring] project rename cannot undo<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=249932">Bug 249932</a>: Clean + project build does not update 'strictly match JRE' problem<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=232710">Bug 232710</a>: [breakpoints] Java breakpoint markers description icon/text missing<br>
<h2>October 7, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=248466">Bug 248466</a>: Cannot launch if build path contains a &quot;..&quot; entry<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=244693">Bug 244693</a>: Default severity for missing JRE for Execution Environment should be Error<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=249490">Bug 249490</a>: JDI fails to unmarshal JDWP reply packet correctly<br>
<h2>August 26, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=189486">Bug 189486</a>: Unable to retrieve system properties for 1.1.8 VM<br>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=245153">Bug 245153</a>: Variable references empty selection: ${java_type_name}<br>
<h2>August 19, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=244285">Bug 244285</a>: An internal error occurred during: &quot;Initializing Java Tooling&quot;.<br>
<h2>3.5 M1 - August 8, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=238350">Bug 238350</a>: Starting Java application (like JBoss) in debug causes NPE. Run mode works ok<br>
<h2>July 8, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=239612">Bug 239612</a>: Use Ctrl+Click instead of Ctrl+Alt for 'Step Into Selection'<br>
<h2>August 12, 2008</h2>
<h3>Problem Reports Fixed</h3>
<a href="http://bugs.eclipse.org/bugs/show_bug.cgi?id=217752">Bug 217752</a>: [logview] provide action to open entry stack trace in console<br>
<p>&nbsp;</p>
</body>
</html>