JavaScript Development Tools

Clone this repo:
  1. 1bfac40 Bug 519774 add update site to reactor by nickboldt · 4 days ago master
  2. 5301e2a inject webtools nexus repos so parent pom can be resolved; by default build with Tycho 1.0 (even if parent pom still at a lower version) by nickboldt · 3 weeks ago
  3. 2d6b022 switch back to deprecated configuration appArgLine so we can build w/ older Tycho versions for now by nickboldt · 3 weeks ago
  4. 175bbd0 add workspace/ reference/ and index/ to gitignore because they're generated files by nickboldt · 3 weeks ago
  5. 7d91261 since we now build with JDK 8, don't use default executionEnvironment = JavaSE-1.7, but rather JavaSE-1.8; also update to use non-deprecated configuration applicationsArgs instead of appArgLine by nickboldt · 3 weeks ago
  6. 95b67eb [519774] - move javascript validation into jsdt.web.ui by Rob Stryker · 7 weeks ago
  7. dacf349 Bug 517659 - com.google.javascript and com.google.guava plugins not added to org.eclipse.wst.jsdt.feature by Victor Rubezhny · 6 months ago R3_9_0 R3_9_1 R3_9_1a
  8. 5eef1ee Bug 487465 - TypeScript debugging by angelozerr · 1 year, 3 months ago
  9. 2aea99e [nobug] Version bump for org.eclipse.wst.jsdt.ui for WTP 3.9.0 (Oxygen) by Victor Rubezhny · 7 months ago
  10. a08c117 Bug 494032 - JSDT features should reference license feature's text. by Roland Grunberg · 8 months ago
  11. 7667f05 Bug 513704 - An NPE exceptions like CompilationUnit.buildStructure() started to appear by Victor Rubezhny · 8 months ago
  12. a34e9ba Bug 513283 - Remove Nashorn hook from JSDT run configuration by Patrik Suzzi · 8 months ago
  13. ba2a63b Bug 513464 - Remove Nashorn extension from JSDT by Victor Rubezhny · 9 months ago
  14. 7daacdc Bug 513341 - "org.eclipse.wst.jsdt.js.node" is requiring "org.eclipse.wst.jsdt.chromium.debug.core" version 0.4.0, and this is not into 4.6.2 build by Victor Rubezhny · 9 months ago
  15. 355cc8a [nobug] Bump features versions for WTP 3.9.0 by Victor Rubezhny · 9 months ago
  16. a0e4358 Bug 513341 - "org.eclipse.wst.jsdt.js.node" is requiring "org.eclipse.wst.jsdt.chromium.debug.core" version 0.4.0, and this is not into 4.6.2 build by Victor Rubezhny · 9 months ago
  17. c847209 Bug 513341 - "org.eclipse.wst.jsdt.js.node" is requiring "org.eclipse.wst.jsdt.chromium.debug.core" version 0.4.0, and this is not into 4.6.2 build by Victor Rubezhny · 9 months ago
  18. 7b92d54 Bug 498371 - Refactor Search to use ASTParser by Angel Misevski · 1 year, 4 months ago
  19. 3c729fe Bug 497249 - Switch to closure compiler for JS parsing by Gorkem Ercan · 1 year, 7 months ago
  20. b19ac27 Bug 512874 - Bower Integration Tests by Pavol Srna · 9 months ago