blob: 711a59dda4644e7c8148ad432d4c51ae75bd18bb [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<setup:ProductCatalog
xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:setup="http://www.eclipse.org/oomph/setup/1.0"
xmlns:setup.p2="http://www.eclipse.org/oomph/setup/p2/1.0"
name="org.eclipse.products"
label="Eclipse.org">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="readmePath">
<value>readme/readme_eclipse.html</value>
</detail>
<detail
key="notificationURI">
<value>https://www.eclipse.org/setups/donate/?scope=${scope}&amp;campaign=2020-12</value>
</detail>
<detail
key="notificationLabel">
<value>DONATE</value>
</detail>
<detail
key="notificationTooltip">
<value>Donate to the Eclipse Community</value>
</detail>
<detail
key="notificationAnimationStyle">
<value>REPEAT</value>
</detail>
</annotation>
<annotation
source="http://www.eclipse.org/oomph/setup/StatsSending">
<detail
key="uri">
<value>http://download.eclipse.org/stats/oomph</value>
</detail>
</annotation>
<setupTask
xsi:type="setup:InstallationTask"
id="installation"/>
<setupTask
xsi:type="setup.p2:P2Task">
<requirement
name="org.eclipse.oomph.setup.feature.group"/>
<repository
url="${oomph.update.url}"/>
</setupTask>
<product name="epp.package.java"
label="Eclipse IDE for Java Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/java.png</value>
</detail>
<detail
key="notificationTooltip">
<value>Donate to the Eclipse Community for the Eclipse IDE for Java Developers</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2021-03)"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2021-03/m2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Latest</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2021-03)">
<requirement
name="epp.package.java"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext.editors_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2021-03/202102251200"/>
<repository
url="http://download.eclipse.org/releases/2021-03/202102261000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (2020-12)"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-12/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Latest Release</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2020-12)">
<requirement
name="epp.package.java"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext.editors_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-12/202012101200"/>
<repository
url="http://download.eclipse.org/releases/2020-12/202012161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2021-03"
label="2021-03"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2021-03/m2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2021-03</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2021-03)">
<requirement
name="epp.package.java"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext.editors_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2021-03/202102251200"/>
<repository
url="http://download.eclipse.org/releases/2021-03/202102261000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-12"
label="2020-12"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>current</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-12/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2020-12</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2020-12)">
<requirement
name="epp.package.java"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext.editors_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-12/202012101200"/>
<repository
url="http://download.eclipse.org/releases/2020-12/202012161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-09"
label="2020-09"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-09/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2020-09</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2020-09)">
<requirement
name="epp.package.java"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext.editors_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-09/202009101200"/>
<repository
url="http://download.eclipse.org/releases/2020-09/202009161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-06"
label="2020-06"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-06/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2020-06</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2020-06)">
<requirement
name="epp.package.java"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.lemminx.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.xml.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-06"/>
<repository
url="http://download.eclipse.org/releases/2020-06/202006171000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-03"
label="2020-03"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-03/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2020-03</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2020-03)">
<requirement
name="epp.package.java"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-03"/>
<repository
url="http://download.eclipse.org/releases/2020-03/202003181000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2019-12"
label="2019-12"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2019-12/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2019-12</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2019-12)">
<requirement
name="epp.package.java"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2019-12"/>
<repository
url="http://download.eclipse.org/releases/2019-12/201912181000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2019-09"
label="2019-09"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2019-09/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2019-09</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2019-09)">
<requirement
name="epp.package.java"
versionRange="[4.13.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.13.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.13.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2019-09"/>
<repository
url="http://download.eclipse.org/releases/2019-09/201909181001">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2019-06"
label="2019-06"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2019-06/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2019-06</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2019-06)">
<requirement
name="epp.package.java"
versionRange="[4.12.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.12.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.12.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2019-06"/>
<repository
url="http://download.eclipse.org/releases/2019-06/201906191000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2019-03"
label="2019-03"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2019-03/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2019-03</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2019-03)">
<requirement
name="epp.package.java"
versionRange="[4.11.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.11.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.11.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2019-03"/>
<repository
url="http://download.eclipse.org/releases/2019-03/201903201000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2018-12"
label="2018-12"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2018-12/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2018-12</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2018-12)">
<requirement
name="epp.package.java"
versionRange="[4.10.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.10.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.10.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-12"/>
<repository
url="http://download.eclipse.org/releases/2018-12/201812191000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2018-09"
label="2018-09"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2018-09/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - 2018-09</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2018-09)">
<requirement
name="epp.package.java"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09/201809191002">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="photon"
label="Photon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/photon/r/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Photon</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Photon)">
<requirement
name="epp.package.java"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="oxygen"
label="Oxygen"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/oxygen/3a/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Oxygen</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Oxygen)">
<requirement
name="epp.package.java"
versionRange="[4.7.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.7.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.7.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/oxygen"/>
<repository
url="http://download.eclipse.org/releases/oxygen/201804111000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="neon"
label="Neon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/neon/3/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Neon</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Neon)">
<requirement
name="epp.package.java"
versionRange="[4.6.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.6.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.6.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/neon"/>
<repository
url="http://download.eclipse.org/releases/neon/201705151400">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="mars"
label="Mars"
requiredJavaVersion="1.7">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/mars/2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Mars</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Mars)">
<requirement
name="epp.package.java"
versionRange="[4.5.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.5.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.5.0,5.0.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.11.0,4.0.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/mars"/>
<repository
url="http://download.eclipse.org/releases/mars/201602261000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="luna"
label="Luna"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/luna/sr2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Luna</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Luna)">
<requirement
name="epp.package.java"
versionRange="[4.4.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.4.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.4.0,5.0.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.10.0,4.0.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/luna"/>
<repository
url="http://download.eclipse.org/releases/luna/201502271000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="kepler"
label="Kepler"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/kepler/sr2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Kepler</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Kepler)">
<requirement
name="epp.package.java"
versionRange="[2.0.0,3.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.3.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.3.0,5.0.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.9.0,4.0.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/kepler"/>
<repository
url="http://download.eclipse.org/releases/kepler/201402280900">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
<repository
url="http://download.eclipse.org/modeling/emf/emf/builds/release/2.24"/>
</setupTask>
</version>
<version
name="juno"
label="Juno"
requiredJavaVersion="1.5">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/juno/sr2/eclipse-ide-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Java Developers - Juno</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Juno)">
<requirement
name="epp.package.java"
versionRange="[1.5.0,2.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.2.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.2.0,5.0.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.8.0,4.0.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/juno"/>
<repository
url="http://download.eclipse.org/releases/juno/201303010900">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
<repository
url="http://download.eclipse.org/modeling/emf/emf/builds/release/2.24"/>
</setupTask>
</version>
<description>The essential tools for any Java developer, including a Java IDE, a Git client, XML Editor, Maven and Gradle integration</description>
</product>
<product name="epp.package.jee"
label="Eclipse IDE for Enterprise Java Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/javaee.png</value>
</detail>
<detail
key="notificationTooltip">
<value>Donate to the Eclipse Community for the Eclipse IDE for Enterprise Java Developers</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2021-03)"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2021-03/m2/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - Latest</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2021-03)">
<requirement
name="epp.package.jee"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.pde.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2021-03/202102251200"/>
<repository
url="http://download.eclipse.org/releases/2021-03/202102261000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (2020-12)"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-12/r/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - Latest Release</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2020-12)">
<requirement
name="epp.package.jee"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-12/202012101200"/>
<repository
url="http://download.eclipse.org/releases/2020-12/202012161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2021-03"
label="2021-03"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2021-03/m2/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2021-03</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2021-03)">
<requirement
name="epp.package.jee"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.19.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.pde.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2021-03/202102251200"/>
<repository
url="http://download.eclipse.org/releases/2021-03/202102261000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-12"
label="2020-12"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>current</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-12/r/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2020-12</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2020-12)">
<requirement
name="epp.package.jee"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.18.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-12/202012101200"/>
<repository
url="http://download.eclipse.org/releases/2020-12/202012161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-09"
label="2020-09"
requiredJavaVersion="11">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-09/r/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2020-09</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2020-09)">
<requirement
name="epp.package.jee"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.17.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.embedder.node.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-09/202009101200"/>
<repository
url="http://download.eclipse.org/releases/2020-09/202009161000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-06"
label="2020-06"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-06/r/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2020-06</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2020-06)">
<requirement
name="epp.package.jee"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.16.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-06"/>
<repository
url="http://download.eclipse.org/releases/2020-06/202006171000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2020-03"
label="2020-03"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2020-03/r/eclipse-ide-enterprise-java-developers-includes-incubating-components</value>
</detail>
<detail
key="incubating">
<value>true</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2020-03</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2020-03)">
<requirement
name="epp.package.jee"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.15.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.mpc.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wildwebdeveloper.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2020-03"/>
<repository
url="http://download.eclipse.org/releases/2020-03/202003181000">
<annotation
source="http://www.eclipse.org/oomph/setup/ReleaseTrain"/>
</repository>
</setupTask>
</version>
<version
name="2019-12"
label="2019-12"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="status">
<value>outdated</value>
</detail>
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/release/2019-12/r/eclipse-ide-enterprise-java-developers</value>
</detail>
<detail
key="shortcut">
<value>Eclipse IDE for Enterprise Java Developers - 2019-12</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Enterprise Java Developers (2019-12)">
<requirement
name="epp.package.jee"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.14.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement