blob: 332408b0ccd3dd72335a4e6313a43759087b95cf [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!--#======================================================================= -->
<!--# Copyright (c) 2011, 2016 - Loetz GmbH&Co.KG (69115 Heidelberg, Germany). -->
<!--# All rights reserved. This program and the accompanying materials -->
<!--# are made available under the terms of the Eclipse Public License 2.0 -->
<!--# which accompanies this distribution, and is available at -->
<!--# https://www.eclipse.org/legal/epl-2.0/ -->
<!--# -->
<!--# SPDX-License-Identifier: EPL-2.0 -->
<!--# -->
<!--# Contributors: -->
<!--# Christophe Loetz (Loetz GmbH&Co.KG) - initial API and implementation -->
<!--#======================================================================= -->
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.eclipse.osbp.dependencies</groupId>
<artifactId>org.eclipse.osbp.dependencies</artifactId>
<version>0.9.0-SNAPSHOT</version>
<relativePath>..</relativePath>
</parent>
<artifactId>org.eclipse.osbp.dependencies.feature.eef</artifactId>
<version>1.5.1-SNAPSHOT</version>
<packaging>eclipse-feature</packaging>
<repositories>
<repository>
<id>emf 1.9</id>
<url>http://download.eclipse.org/modeling/emft/eef/updates/releases/1.9</url>
<layout>p2</layout>
</repository>
<repository>
<id>ecoretools 3.2.0</id>
<url>http://download.eclipse.org/ecoretools/updates/releases/3.2.0/neon</url>
<layout>p2</layout>
</repository>
</repositories>
<dependencies>
<!-- CQ: not needed, its all based on Eclipse projects -->
<dependency>
<groupId>org.eclipse.osbp.dependencies</groupId>
<artifactId>org.eclipse.osbp.dependencies.feature.sirius</artifactId>
<version>4.1.1-SNAPSHOT</version>
<type>eclipse-feature</type>
</dependency>
</dependencies>
<build>
<plugins>
<plugin>
<!-- workaround while bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=398250
is not fixed -->
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-plugin</artifactId>
<version>${tycho-version}</version>
<executions>
<execution>
<id>attached-p2-metadata</id>
<phase>package</phase>
<goals>
<goal>p2-metadata</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
</build>
</project>