Eclipse Platform Aggregator

Clone this repo:
  1. cb4ccb0 Bug 542620 - Create a new script for generation environment files by Sravan Kumar Lakkimsetti · 9 hours ago master
  2. 2ea47dc Bug 541823 - Update Comparator repo and eclipse run repo to 4.11-I-builds repo by Sravan Kumar Lakkimsetti · 3 days ago I20181210-0755
  3. 2a4cc92 Build input for build I20181210-0535 by genie.releng · 11 hours ago I20181210-0535
  4. 9dbf457 Bug 539334 - Test job should only require build-id by Kalyan Prasad Tatavarthi · 12 hours ago
  5. 0b0dcc6 Bug 541826 - Move previous version to 4.10 across build scripts by Sravan Kumar Lakkimsetti · 2 days ago

eclipse.platform.releng.aggregator

Aggregator repo for Eclipse SDK builds.

To run a complete build, on your local machine, run the commands from ./scripts/build.sh in this folder.

These commands requires the installation and setup of Java 1.8 or higher and Maven version 3.5.4 or higher Plus, other settings, alternatives, and other recommendations are made in the complete instructions on the Platform Build wiki. Note, it is highly recommended to use toolchains.xml and -Pbree-libs as decribed in Using BREE Libs. If you do use BREE Libs (with proper toolchains.xml file) you can use Java 1.7 to “run the build”.

Eclipse Platform Project committers should also read Automated Platform Builds.

Release Engineers should also be familiar with other documents on the Releng Wiki.

License

Eclipse Public License (EPL) v1.0