Bug 507651 - Move eclipse.platform.releng.buildtools to Tycho 0.26

Bump Tycho version and also add Maven prereq so mvn
versions:display-plugin-reports shows saner output.

Change-Id: Icde6c4aa6dd23dfdac878545d431e06e67033ac2
Signed-off-by: Alexander Kurtakov <akurtako@redhat.com>
diff --git a/pom.xml b/pom.xml
index 92b9736..ac04d00 100644
--- a/pom.xml
+++ b/pom.xml
@@ -18,9 +18,13 @@
   <artifactId>eclipse.platform.releng.buildtools</artifactId>
   <version>1.0.101-SNAPSHOT</version>
   <packaging>pom</packaging>
+  <prerequisites>
+    <maven>3.1.1</maven>
+  </prerequisites>
+
   <properties>
-    <tycho.version>0.25.0</tycho.version>
-    <tycho-extras.version>0.25.0</tycho-extras.version>
+    <tycho.version>0.26.0</tycho.version>
+    <tycho-extras.version>0.26.0</tycho-extras.version>
     <cbi-plugins.version>1.1.3</cbi-plugins.version>
     <maven.build.timestamp.format>yyyyMMdd-HHmm</maven.build.timestamp.format>
     <buildTimestamp>${maven.build.timestamp}</buildTimestamp>