[548631] Avoid breaking compat in DialectServices.copyRepresentation()

Keep a version of DialectServices.copyRepresentation() which takes a
DRepresentation available, but deprecated, to avoid an API break that
is not strictly required.

But: 548631
Change-Id: I5cc0790a6b1ec50cbf2b60d552e829d466c5320d
Signed-off-by: Pierre-Charles David <pierre-charles.david@obeo.fr>
3 files changed
tree: 5dcb9ba276d7e69641a3b101507acb52937efd6f
  1. .gitattributes
  2. .gitignore
  3. .travis.yml
  4. CONTRIBUTING
  5. Jenkinsfile
  6. LICENSE
  7. NOTICE
  8. README.md
  9. build.sh
  10. packaging/
  11. plugins/
  12. pom.xml
  13. releng/
README.md

Eclipse Sirius

Build Status

Sirius enables the specification of a modeling workbench in terms of graphical, table or tree editors with validation rules and actions using declarative descriptions.

For more details see the project page and the main wiki page.

Building

The build uses Tycho. To launch a complete build, issue

mvn clean package

from the top-level directory. The resulting update-site (p2 repository) can be found in packaging/org.eclipse.sirius.update/target/repository.

By default the build uses a Neon-based target platform. You can specify a different platform like this:

mvn clean package -Dplatform-version-name=name

where name can be any of the following values:

  • mars (Eclipse 4.5)
  • neon (Eclipse 4.6, the default and reference target platform)
  • canary (uses nightly builds of all our dependencies, only used for testing)

The corresponding target platform definitions can be found in releng/org.eclipse.sirius.targets.