387796 Update default execution environment to JavaSE-1.6

- If no execution environment is specified in POM and Manifest, use
  JavaSE-1.6 as default so that the p2 dependency resolver doesn't
  report strange problems.
- The execution environment also determines the compiler source/target
  level, so for projects which neither have an explicit execution
  environment nor an explicit compiler configuration, the default
  source/target is changed to 1.6.
- Also set the last resort compiler source/target default to 1.6. This
  value is only used if a custom execution environment is used and there
  is no explicit compiler configuration.

Bug: 387796
Change-Id: I442227534f7f9eae56894b79757886c76bdd738e
4 files changed