[477861] Remove dependency on org.eclipse.core.runtime.compatibility
bundle
diff --git a/tests/org.eclipse.wst.common.tests.collector/META-INF/MANIFEST.MF b/tests/org.eclipse.wst.common.tests.collector/META-INF/MANIFEST.MF
index ee219d6..f3a87e4 100644
--- a/tests/org.eclipse.wst.common.tests.collector/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.wst.common.tests.collector/META-INF/MANIFEST.MF
@@ -2,12 +2,12 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %org.eclipse.wst.common.tests.collector
 Bundle-SymbolicName: org.eclipse.wst.common.tests.collector; singleton:=true
-Bundle-Version: 1.1.0.qualifier
+Bundle-Version: 1.1.100.qualifier
 Bundle-ClassPath: runtime/collector.jar
-Bundle-Activator: org.eclipse.core.internal.compatibility.PluginActivator
+Bundle-Activator: org.eclipse.wst.common.tests.collector.TestCollectorPlugin
 Bundle-Localization: plugin
 Require-Bundle: org.junit,
  org.eclipse.ui,
- org.eclipse.core.runtime.compatibility
+ org.eclipse.core.runtime
 Eclipse-LazyStart: true
 Bundle-RequiredExecutionEnvironment: J2SE-1.4
diff --git a/tests/org.eclipse.wst.common.tests.collector/collector/org/eclipse/wst/common/tests/collector/TestCollectorPlugin.java b/tests/org.eclipse.wst.common.tests.collector/collector/org/eclipse/wst/common/tests/collector/TestCollectorPlugin.java
new file mode 100644
index 0000000..9780327
--- /dev/null
+++ b/tests/org.eclipse.wst.common.tests.collector/collector/org/eclipse/wst/common/tests/collector/TestCollectorPlugin.java
@@ -0,0 +1,32 @@
+/*******************************************************************************
+ * Copyright (c) 2015 IBM Corporation and others.
+ * All rights reserved. This program and the accompanying materials
+ * are made available under the terms of the Eclipse Public License v1.0
+ * which accompanies this distribution, and is available at
+ * http://www.eclipse.org/legal/epl-v10.html
+ *
+ * Contributors:
+ * IBM Corporation - initial API and implementation
+ *******************************************************************************/
+package org.eclipse.wst.common.tests.collector;
+
+import org.eclipse.core.runtime.IExtensionPoint;
+import org.eclipse.core.runtime.IPluginDescriptor;
+import org.eclipse.core.runtime.Plugin;
+
+
+public class TestCollectorPlugin extends Plugin {
+	public static String PLUGIN_ID = "org.eclipse.wst.common.tests.collector";
+	public static TestCollectorPlugin instance = null;
+	public IExtensionPoint dataModelVerifierExt = null;
+	
+	/**
+	 * @param descriptor
+	 */
+	public TestCollectorPlugin(IPluginDescriptor descriptor) {
+		super(descriptor);
+		instance = this;
+		dataModelVerifierExt = descriptor.getExtensionPoint("DataModelVerifier");
+	}
+
+}
diff --git a/tests/org.eclipse.wst.common.tests/META-INF/MANIFEST.MF b/tests/org.eclipse.wst.common.tests/META-INF/MANIFEST.MF
index e2e3abb..fe8f2ce 100644
--- a/tests/org.eclipse.wst.common.tests/META-INF/MANIFEST.MF
+++ b/tests/org.eclipse.wst.common.tests/META-INF/MANIFEST.MF
@@ -2,9 +2,9 @@
 Bundle-ManifestVersion: 2
 Bundle-Name: %Bundle-Name.0
 Bundle-SymbolicName: org.eclipse.wst.common.tests; singleton:=true
-Bundle-Version: 1.2.300.qualifier
+Bundle-Version: 1.2.400.qualifier
 Bundle-ClassPath: commontests.jar
-Bundle-Activator: org.eclipse.core.internal.compatibility.PluginActivator
+Bundle-Activator: org.eclipse.wst.common.tests.CommonTestsPlugin
 Bundle-Vendor: %Bundle-Vendor.0
 Export-Package: org.eclipse.etools.common.test.apitools,
  org.eclipse.wst.common.environment.tests,
@@ -19,7 +19,6 @@
  org.eclipse.wst.common.tests.xml
 Require-Bundle: org.junit;visibility:=reexport,
  org.eclipse.core.resources;visibility:=reexport,
- org.eclipse.core.runtime.compatibility,
  org.eclipse.wst.common.frameworks;visibility:=reexport,
  org.eclipse.wst.common.emfworkbench.integration,
  org.eclipse.emf.common,
@@ -31,7 +30,8 @@
  org.eclipse.wst.common.environment,
  org.eclipse.wst.common.emf,
  org.eclipse.wst.validation;bundle-version="1.2.0",
- org.eclipse.wst.common.uriresolver.tests
+ org.eclipse.wst.common.uriresolver.tests,
+ org.eclipse.core.runtime
 Eclipse-LazyStart: true
 Plugin-Class: org.eclipse.wst.common.tests.CommonTestsPlugin
 Bundle-RequiredExecutionEnvironment: J2SE-1.5