Remove references to specific front-end dev tools

If necessary, the front-end dev tools will be fetched transitively,
but let's not make it explicit as not everyone wants to use WTP (for
example some use Genuitec CodeMix or Wild Web Developer).

Change-Id: If8dc632776206aa35fdd45044b89cd93bb28152e
Signed-off-by: Mickael Istria <mistria@redhat.com>
diff --git a/org.eclipse.m2e.wtp.jaxrs.feature/feature.xml b/org.eclipse.m2e.wtp.jaxrs.feature/feature.xml
index a5e4a1c..62ff410 100644
--- a/org.eclipse.m2e.wtp.jaxrs.feature/feature.xml
+++ b/org.eclipse.m2e.wtp.jaxrs.feature/feature.xml
@@ -18,20 +18,9 @@
    </copyright>
 
    <requires>
-      <!--
-      <import plugin="org.eclipse.wst.common.frameworks"/>
-      <import plugin="org.eclipse.wst.common.modulecore"/>
-      <import plugin="org.eclipse.wst.common.project.facet.core"/>
-      <import plugin="org.eclipse.jst.common.frameworks"/>
-      <import plugin="org.eclipse.jst.common.project.facet.core"/>
-      <import plugin="org.eclipse.jst.j2ee.web"/>
-      <import plugin="org.eclipse.jst.j2ee"/>
-      <import plugin="org.eclipse.jst.j2ee.core"/>
-      -->
       <import feature="org.eclipse.platform" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.rcp" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jdt" version="3.6.0" match="greaterOrEqual"/>
-      <import feature="org.eclipse.wst.web_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.enterprise_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.wst.common.fproj" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.common.fproj.enablement.jdt" version="3.2.0" match="greaterOrEqual"/>
diff --git a/org.eclipse.m2e.wtp.jpa.feature/feature.xml b/org.eclipse.m2e.wtp.jpa.feature/feature.xml
index 765e6cc..d30d7f7 100644
--- a/org.eclipse.m2e.wtp.jpa.feature/feature.xml
+++ b/org.eclipse.m2e.wtp.jpa.feature/feature.xml
@@ -18,20 +18,9 @@
    </copyright>
 
    <requires>
-      <!--
-      <import plugin="org.eclipse.wst.common.frameworks"/>
-      <import plugin="org.eclipse.wst.common.modulecore"/>
-      <import plugin="org.eclipse.wst.common.project.facet.core"/>
-      <import plugin="org.eclipse.jst.common.frameworks"/>
-      <import plugin="org.eclipse.jst.common.project.facet.core"/>
-      <import plugin="org.eclipse.jst.j2ee.web"/>
-      <import plugin="org.eclipse.jst.j2ee"/>
-      <import plugin="org.eclipse.jst.j2ee.core"/>
-      -->
       <import feature="org.eclipse.platform" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.rcp" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jdt" version="3.6.0" match="greaterOrEqual"/>
-      <import feature="org.eclipse.wst.web_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.enterprise_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.wst.common.fproj" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.common.fproj.enablement.jdt" version="3.2.0" match="greaterOrEqual"/>
diff --git a/org.eclipse.m2e.wtp.jsf.feature/feature.xml b/org.eclipse.m2e.wtp.jsf.feature/feature.xml
index 3aeb1d3..97f34a7 100644
--- a/org.eclipse.m2e.wtp.jsf.feature/feature.xml
+++ b/org.eclipse.m2e.wtp.jsf.feature/feature.xml
@@ -21,7 +21,6 @@
       <import feature="org.eclipse.platform" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.rcp" version="3.6.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jdt" version="3.6.0" match="greaterOrEqual"/>
-      <import feature="org.eclipse.wst.web_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.enterprise_ui.feature" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.wst.common.fproj" version="3.2.0" match="greaterOrEqual"/>
       <import feature="org.eclipse.jst.common.fproj.enablement.jdt" version="3.2.0" match="greaterOrEqual"/>