blob: f7b78058e53e02848048e8f99d8dbbd685ae0363 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<setup:ProductCatalog
xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:setup="http://www.eclipse.org/oomph/setup/1.0"
xmlns:setup.p2="http://www.eclipse.org/oomph/setup/p2/1.0"
name="org.eclipse.products"
label="Eclipse.org">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="readmePath">
<value>readme/readme_eclipse.html</value>
</detail>
</annotation>
<annotation
source="http://www.eclipse.org/oomph/setup/StatsSending">
<detail
key="uri">
<value>http://download.eclipse.org/stats/oomph</value>
</detail>
</annotation>
<setupTask
xsi:type="setup:InstallationTask"
id="installation"/>
<setupTask
xsi:type="setup.p2:P2Task">
<requirement
name="org.eclipse.oomph.setup.feature.group"/>
<repository
url="${oomph.update.url}"/>
</setupTask>
<product name="epp.package.java"
label="Eclipse IDE for Java Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/java.png</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2018-09)"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2018-09)">
<requirement
name="epp.package.java"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Photon)">
<requirement
name="epp.package.java"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="2018-09"
label="2018-09"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (2018-09)">
<requirement
name="epp.package.java"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="photon"
label="Photon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Photon)">
<requirement
name="epp.package.java"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="oxygen"
label="Oxygen"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/oxygen3a</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Oxygen)">
<requirement
name="epp.package.java"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.news.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/oxygen"/>
<repository
url="http://download.eclipse.org/releases/oxygen/201804111000"/>
</setupTask>
</version>
<version
name="neon"
label="Neon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/neon3</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Neon)">
<requirement
name="epp.package.java"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jgit.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.git.feature.group"/>
<requirement
name="org.eclipse.mylyn.hudson.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.snipmatch.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/neon"/>
<repository
url="http://download.eclipse.org/releases/neon/201705151400"/>
</setupTask>
</version>
<version
name="mars"
label="Mars"
requiredJavaVersion="1.7">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/mars2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Mars)">
<requirement
name="epp.package.java"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.11.0,3.12.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/mars"/>
<repository
url="http://download.eclipse.org/releases/mars/201602261000"/>
</setupTask>
</version>
<version
name="luna"
label="Luna"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Luna)">
<requirement
name="epp.package.java"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.10.0,3.11.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/luna"/>
<repository
url="http://download.eclipse.org/releases/luna/201502271000"/>
</setupTask>
</version>
<version
name="kepler"
label="Kepler"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/keplersr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Kepler)">
<requirement
name="epp.package.java"
versionRange="[2.0.0,2.1.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.9.0,3.10.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/kepler"/>
<repository
url="http://download.eclipse.org/releases/kepler/201402280900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<version
name="juno"
label="Juno"
requiredJavaVersion="1.5">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/junosr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java Developers (Juno)">
<requirement
name="epp.package.java"
versionRange="[1.5.0,1.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.8.0,3.9.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/juno"/>
<repository
url="http://download.eclipse.org/releases/juno/201303010900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<description>The essential tools for any Java developer, including a Java IDE, a Git client, XML Editor, Mylyn, Maven and Gradle integration</description>
</product>
<product name="epp.package.jee"
label="Eclipse IDE for Java EE Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/javaee.png</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Photon)">
<requirement
name="epp.package.jee"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,5.0.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.dbws.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Photon)">
<requirement
name="epp.package.jee"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.dbws.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="photon"
label="Photon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Photon)">
<requirement
name="epp.package.jee"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.apache.derby.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.hsqldb.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ibm.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.ingres.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdbc.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.jdt.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.msft.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.mysql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.designer.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oda.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.oracle.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.postgresql.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sap.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sqlite.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.sybase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sdk.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.data.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddl.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.parsers.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.results.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.dbws.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="oxygen"
label="Oxygen"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/oxygen3a</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Oxygen)">
<requirement
name="epp.package.jee"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.buildship.feature.group"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.eclemma.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.dbws.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.rse.useractions.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/oxygen"/>
<repository
url="http://download.eclipse.org/releases/oxygen/201804111000"/>
</setupTask>
</version>
<version
name="neon"
label="Neon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/neon3</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Neon)">
<requirement
name="epp.package.jee"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.cft.server.core.feature.feature.group"/>
<requirement
name="org.eclipse.cft.server.ui.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.common.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.connectivity.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.doc.user.feature.group"/>
<requirement
name="org.eclipse.datatools.enablement.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.intro.feature.group"/>
<requirement
name="org.eclipse.datatools.modelbase.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqldevtools.feature.feature.group"/>
<requirement
name="org.eclipse.datatools.sqltools.doc.user.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.jdt.feature.group"/>
<requirement
name="org.eclipse.jpt.common.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.common.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.dbws.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jaxb.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.eclipselink.feature.feature.group"/>
<requirement
name="org.eclipse.jpt.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.common.fproj.enablement.jdt.feature.group"/>
<requirement
name="org.eclipse.jst.enterprise_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.ext.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.jst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.jst.webpageeditor.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.axis2tools.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.cxf.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.dom.feature.feature.group"/>
<requirement
name="org.eclipse.jst.ws.jaxws.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.logback.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jaxrs.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jpa.feature.feature.group"/>
<requirement
name="org.eclipse.m2e.wtp.jsf.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.java_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.pde.feature.group"/>
<requirement
name="org.eclipse.recommenders.mylyn.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.recommenders.rcp.feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.rse.useractions.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.common.fproj.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xsl.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/neon"/>
<repository
url="http://download.eclipse.org/releases/neon/201705151400"/>
</setupTask>
</version>
<version
name="mars"
label="Mars"
requiredJavaVersion="1.7">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/mars2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Mars)">
<requirement
name="epp.package.jee"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.11.0,3.12.0)"/>
<requirement
name="org.eclipse.pde.feature.group"
versionRange="[3.11.0,3.12.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/mars"/>
<repository
url="http://download.eclipse.org/releases/mars/201602261000"/>
</setupTask>
</version>
<version
name="luna"
label="Luna"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/lunasr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Luna)">
<requirement
name="epp.package.jee"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.10.0,3.11.0)"/>
<requirement
name="org.eclipse.pde.feature.group"
versionRange="[3.10.0,3.11.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/luna"/>
<repository
url="http://download.eclipse.org/releases/luna/201502271000"/>
</setupTask>
</version>
<version
name="kepler"
label="Kepler"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/keplersr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Kepler)">
<requirement
name="epp.package.jee"
versionRange="[2.0.0,2.1.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.9.0,3.10.0)"/>
<requirement
name="org.eclipse.pde.feature.group"
versionRange="[3.9.0,3.10.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/kepler"/>
<repository
url="http://download.eclipse.org/releases/kepler/201402280900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<version
name="juno"
label="Juno"
requiredJavaVersion="1.5">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/junosr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for Java EE Developers (Juno)">
<requirement
name="epp.package.jee"
versionRange="[1.5.0,1.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<requirement
name="org.eclipse.jdt.feature.group"
versionRange="[3.8.0,3.9.0)"/>
<requirement
name="org.eclipse.pde.feature.group"
versionRange="[3.8.0,3.9.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/juno"/>
<repository
url="http://download.eclipse.org/releases/juno/201303010900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<description>Tools for Java developers creating Java EE and Web applications, including a Java IDE, tools for Java EE, JPA, JSF, Mylyn, EGit and others.</description>
</product>
<product name="epp.package.cpp"
label="Eclipse IDE for C/C++ Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/cdt.png</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2018-09)"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (2018-09)">
<requirement
name="epp.package.cpp"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.cdt.arduino.feature.group"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.cmake.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.gdbjtag.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.docker.launcher.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.serial.feature.feature.group"/>
<requirement
name="org.eclipse.cdt.meson.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.cdt.qt.feature.group"/>
<requirement
name="org.eclipse.cdt.testsrunner.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.connector.cdtserial.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Photon)">
<requirement
name="epp.package.cpp"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.cdt.arduino.feature.group"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.cmake.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.gdbjtag.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.docker.launcher.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.serial.feature.feature.group"/>
<requirement
name="org.eclipse.cdt.meson.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.cdt.qt.feature.group"/>
<requirement
name="org.eclipse.cdt.testsrunner.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.connector.cdtserial.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="2018-09"
label="2018-09"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (2018-09)">
<requirement
name="epp.package.cpp"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.cdt.arduino.feature.group"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.cmake.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.gdbjtag.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.docker.launcher.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.serial.feature.feature.group"/>
<requirement
name="org.eclipse.cdt.meson.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.cdt.qt.feature.group"/>
<requirement
name="org.eclipse.cdt.testsrunner.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.connector.cdtserial.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="photon"
label="Photon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Photon)">
<requirement
name="epp.package.cpp"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.cdt.arduino.feature.group"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.cmake.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.gdbjtag.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.docker.launcher.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.serial.feature.feature.group"/>
<requirement
name="org.eclipse.cdt.meson.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.cdt.qt.feature.group"/>
<requirement
name="org.eclipse.cdt.testsrunner.feature.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.connector.cdtserial.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="oxygen"
label="Oxygen"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/oxygen3a</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Oxygen)">
<requirement
name="epp.package.cpp"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.connector.cdtserial.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/oxygen"/>
<repository
url="http://download.eclipse.org/releases/oxygen/201804111000"/>
</setupTask>
</version>
<version
name="neon"
label="Neon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/neon3</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Neon)">
<requirement
name="epp.package.cpp"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.cdt.autotools.feature.group"/>
<requirement
name="org.eclipse.cdt.build.crossgcc.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.standalone.feature.group"/>
<requirement
name="org.eclipse.cdt.debug.ui.memory.feature.group"/>
<requirement
name="org.eclipse.cdt.feature.group"/>
<requirement
name="org.eclipse.cdt.launch.remote.feature.group"/>
<requirement
name="org.eclipse.cdt.mylyn.feature.group"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.devhelp.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.cdt.libhover.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.changelog.c.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gcov.feature.group"/>
<requirement
name="org.eclipse.linuxtools.gprof.feature.feature.group"/>
<requirement
name="org.eclipse.linuxtools.rpm.feature.group"/>
<requirement
name="org.eclipse.linuxtools.valgrind.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.team_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.tracecompass.gdbtrace.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.control.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.kernel.feature.group"/>
<requirement
name="org.eclipse.tracecompass.lttng2.ust.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/neon"/>
<repository
url="http://download.eclipse.org/releases/neon/201705151400"/>
</setupTask>
</version>
<version
name="mars"
label="Mars"
requiredJavaVersion="1.7">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/mars2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Mars)">
<requirement
name="epp.package.cpp"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.5.0,4.6.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/mars"/>
<repository
url="http://download.eclipse.org/releases/mars/201602261000"/>
</setupTask>
</version>
<version
name="luna"
label="Luna"
requiredJavaVersion="1.7">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/lunasr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Luna)">
<requirement
name="epp.package.cpp"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.4.0,4.5.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/luna"/>
<repository
url="http://download.eclipse.org/releases/luna/201502271000"/>
</setupTask>
</version>
<version
name="kepler"
label="Kepler"
requiredJavaVersion="1.6">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/keplersr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Kepler)">
<requirement
name="epp.package.cpp"
versionRange="[2.0.0,2.1.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.3.0,4.4.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/kepler"/>
<repository
url="http://download.eclipse.org/releases/kepler/201402280900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<version
name="juno"
label="Juno"
requiredJavaVersion="1.5">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/junosr2</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for C/C++ Developers (Juno)">
<requirement
name="epp.package.cpp"
versionRange="[1.5.0,1.6.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.2.0,4.3.0)"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/juno"/>
<repository
url="http://download.eclipse.org/releases/juno/201303010900"/>
<repository
url="http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/core/S201501230452"/>
</setupTask>
</version>
<description>An IDE for C/C++ developers with Mylyn integration.</description>
</product>
<product name="epp.package.javascript"
label="Eclipse IDE for JavaScript and Web Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/javascript.png</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2018-09)"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (2018-09)">
<requirement
name="epp.package.javascript"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (Photon)">
<requirement
name="epp.package.javascript"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="2018-09"
label="2018-09"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (2018-09)">
<requirement
name="epp.package.javascript"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,4.10.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="photon"
label="Photon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (Photon)">
<requirement
name="epp.package.javascript"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.tips.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>
</setupTask>
</version>
<version
name="oxygen"
label="Oxygen"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/oxygen3a</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (Oxygen)">
<requirement
name="epp.package.javascript"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.7.0,4.8.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/oxygen"/>
<repository
url="http://download.eclipse.org/releases/oxygen/201804111000"/>
</setupTask>
</version>
<version
name="neon"
label="Neon"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/neon3</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for JavaScript and Web Developers (Neon)">
<requirement
name="epp.package.javascript"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.6.0,4.7.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.epp.package.common.feature.feature.group"/>
<requirement
name="org.eclipse.equinox.p2.user.ui.feature.group"/>
<requirement
name="org.eclipse.help.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.rse.feature.group"/>
<requirement
name="org.eclipse.thym.feature.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.chromium.debug.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.json_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_adapters.feature.feature.group"/>
<requirement
name="org.eclipse.wst.server_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.web_ui.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/neon"/>
<repository
url="http://download.eclipse.org/releases/neon/201705151400"/>
</setupTask>
</version>
<description>The essential tools for any JavaScript developer, including JavaScript, HTML, CSS, XML languages support, Git client, and Mylyn.</description>
</product>
<product name="epp.package.php"
label="Eclipse IDE for PHP Developers">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="imageURI">
<value>http://www.eclipse.org/downloads/images/php.png</value>
</detail>
</annotation>
<version
name="latest"
label="Latest (2018-09)"
requiredJavaVersion="1.8">
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for PHP Developers (2018-09)">
<requirement
name="epp.package.php"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.9.0,5.0.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.php.composer.feature.group"/>
<requirement
name="org.eclipse.php.feature.group"/>
<requirement
name="org.eclipse.php.mylyn.feature.group"/>
<requirement
name="org.eclipse.php.phpunit.feature.feature.group"/>
<requirement
name="org.eclipse.php.profiler.feature.group"/>
<requirement
name="org.eclipse.php.rdt.sync.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/2018-09"/>
<repository
url="http://download.eclipse.org/releases/2018-09"/>
</setupTask>
</version>
<version
name="latest.released"
label="Latest Release (Photon)"
requiredJavaVersion="1.8">
<annotation
source="http://www.eclipse.org/oomph/setup/BrandingInfo">
<detail
key="siteURI">
<value>https://www.eclipse.org/downloads/packages/eclipse-ide-php-developers/photonr</value>
</detail>
</annotation>
<setupTask
xsi:type="setup.p2:P2Task"
label="Eclipse IDE for PHP Developers (Photon)">
<requirement
name="epp.package.php"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.platform.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.rcp.feature.group"
versionRange="[4.8.0,4.9.0)"/>
<requirement
name="org.eclipse.egit.feature.group"/>
<requirement
name="org.eclipse.egit.gitflow.feature.feature.group"/>
<requirement
name="org.eclipse.egit.mylyn.feature.group"/>
<requirement
name="org.eclipse.mylyn.bugzilla_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.context_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.github.feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.ide_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn.wikitext_feature.feature.group"/>
<requirement
name="org.eclipse.mylyn_feature.feature.group"/>
<requirement
name="org.eclipse.php.composer.feature.group"/>
<requirement
name="org.eclipse.php.feature.group"/>
<requirement
name="org.eclipse.php.mylyn.feature.group"/>
<requirement
name="org.eclipse.php.phpunit.feature.feature.group"/>
<requirement
name="org.eclipse.php.profiler.feature.group"/>
<requirement
name="org.eclipse.php.rdt.sync.feature.group"/>
<requirement
name="org.eclipse.tm.terminal.feature.feature.group"/>
<requirement
name="org.eclipse.wst.jsdt.feature.feature.group"/>
<requirement
name="org.eclipse.wst.xml_ui.feature.feature.group"/>
<repository
url="http://download.eclipse.org/technology/epp/packages/photon"/>
<repository
url="http://download.eclipse.org/releases/photon/201806271001"/>